CloneCurvesContext Class
Algorithmic class for cloning curve collections.
- recurse through collection nodes, building image nodes as needed and inserting clones of children.
- for individual primitive, invoke doClone (protected) for direct clone; insert into parent
Extends
Methods
Name | Description | |
---|---|---|
constructor(transform?: Transform): CloneCurvesContext Protected | ||
announceCurvePrimitive(primitive: CurvePrimitive, _indexInParent: number): void | process a leaf primitive. | |
doClone(primitive: CurvePrimitive): undefined | CurvePrimitive | CurvePrimitive[] Protected | ||
enter(c: CurveCollection): void | Push data onto the stack so its status is available during processing of children. |
|
leave(): undefined | CurveCollection | Pop the stack | |
clone(target: CurveCollection, transform?: Transform): undefined | CurveCollection Static |
Inherited methods
Name | Inherited from | Description |
---|---|---|
announceBagOfCurves(data: BagOfCurves, _indexInParent: number-1): void Inherited | RecursiveCurveProcessorWithStack | Announce members of an unstructured collection. |
announceLoop(data: Loop, indexInParent: number-1): void Inherited | RecursiveCurveProcessorWithStack | announce a loop (recurse to children) |
announceParityRegion(data: ParityRegion, _indexInParent: number-1): void Inherited | RecursiveCurveProcessorWithStack | announce beginning or end of loops in a parity region |
announcePath(data: Path, indexInParent: number-1): void Inherited | RecursiveCurveProcessorWithStack | announce a path (recurse to children) |
announceUnexpected(_data: AnyCurve, _indexInParent: number): void Inherited | RecursiveCurveProcessorWithStack | process error content |
announceUnionRegion(data: UnionRegion, indexInParent: number-1): void Inherited | RecursiveCurveProcessorWithStack | announce beginning or end of a parity region |
Properties
Name | Type | Description | |
---|---|---|---|
_result Protected | undefined | CurveCollection |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_stack Protected Inherited | CurveCollection[] | RecursiveCurveProcessorWithStack | Stack of curve collections that are "up the tree" from the current point of the traversal. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.