createFromMatrix3d MethodStatic
Attempts to create a YawPitchRollAngles object from a Matrix3d.
createFromMatrix3d(matrix: Matrix3d, result?: YawPitchRollAngles): undefined | YawPitchRollAngles
@returns computed angles, or undefined if matrix
is not rigid.
- Even when undefined is returned,
result
(if supplied) is populated with angles that may be used with caution: their usefulness decreases the furthermatrix
is from being rigid.
Parameter | Type | Description |
---|---|---|
matrix | Matrix3d | rigid matrix to process. Caller can test for rigidity with isRigid and ensure rigid input with createRigidFromMatrix3d or makeRigid. |
result | YawPitchRollAngles | optional pre-allocated object to populate and return. |
Returns - undefined | YawPitchRollAngles
computed angles, or undefined if matrix
is not rigid.
- Even when undefined is returned,
result
(if supplied) is populated with angles that may be used with caution: their usefulness decreases the furthermatrix
is from being rigid.
Defined in
- geometry3d/YawPitchRollAngles.ts Line 270
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.