isRigid Method
Test if the matrix is a rigid matrix.
- A rigid matrix is a rotation: its columns and rows are unit length and pairwise perpendicular, and its determinant is +1.
isRigid(allowMirror: booleanfalse): boolean
Parameter | Type | Description |
---|---|---|
allowMirror | boolean | whether to widen the test to also return true if the matrix is a mirror (determinant is -1). |
Returns - boolean
Defined in
- geometry3d/Matrix3d.ts Line 2771
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.