makeRigid Method
Adjust the matrix in place to make is a rigid
matrix so that:
- columns are perpendicular and have unit length.
- transpose equals inverse.
- mirroring is removed.
- This function internally uses
axisOrderCrossProductsInPlace
to make the matrix rigid.
makeRigid(axisOrder: AxisOrderAxisOrder.XYZ): boolean
@returns whether the adjusted matrix is rigid
on return
Parameter | Type | Description |
---|---|---|
axisOrder | AxisOrder | how to reorder the matrix columns |
Returns - boolean
whether the adjusted matrix is rigid
on return
Defined in
- geometry3d/Matrix3d.ts Line 2812
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.