AxisOrder Enumeration
Enumeration of the 6 possible orderings of XYZ axis order
- Note: There are 3 axis order with right hand system (XYZ = 0, YZX = 1, ZXY = 2) and 3 axis order with
left hand system (XZY = 4, YXZ = 5, ZYX = 6). Note that
AxisOrder
is encoding the handedness as well. Cross product of the i_th axis in an ordering (i=0,1,2), with the i+1_th in that ordering, will produce the i+2_th axis in that ordering.
Members
Defined in
- Geometry.ts Line 26
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.