createRigidFromMatrix3d MethodStatic
Create a new orthogonal matrix (perpendicular columns, unit length, transpose is inverse).
- Columns are taken from the source Matrix3d in order indicated by the axis order.
- Mirroring in the matrix is removed.
- This function internally uses
axisOrderCrossProductsInPlace
to make the matrix rigid.
createRigidFromMatrix3d(source: Matrix3d, axisOrder: AxisOrderAxisOrder.XYZ, result?: Matrix3d): undefined | Matrix3d
Parameter | Type | Description |
---|---|---|
source | Matrix3d | |
axisOrder | AxisOrder | |
result | Matrix3d |
Returns - undefined | Matrix3d
Defined in
- geometry3d/Matrix3d.ts Line 2827
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.