ViewPose2d Class
The "pose" for a ViewState2d.
Extends
Methods
Name | Description | |
---|---|---|
constructor(view: ViewState2d): ViewPose2d | Construct a pose from the specified 2d view. | |
equal(other: ViewPose): boolean | See ViewPose.equal. | |
equalState(view: ViewState): boolean | See equalState. |
Properties
Name | Type | Description | |
---|---|---|---|
angle Readonly | Angle | The rotation of the view. | |
delta Readonly | Point2d | The 2d extents of the view. | |
extents Accessor ReadOnly | Vector3d | See extents. | |
origin Accessor ReadOnly | Point3d | See ViewPose.origin. | |
origin2d Readonly | Point2d | The 2d origin of the view. | |
rotation Accessor ReadOnly | Matrix3d | See rotation. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
cameraOn | boolean | ViewPose | True if the camera is enabled. |
center Accessor ReadOnly | Point3d | ViewPose | Computes the center of the viewed volume. |
target Accessor ReadOnly | Point3d | ViewPose | Returns the target point of the view. This is the same as center unless cameraOn is true . |
undoTime | BeTimePoint | undefined | ViewPose | The time at which this pose was created, if it was saved into a Viewport's undo stack. |
zVec Accessor ReadOnly | Vector3d | ViewPose | Computes the Z vector of the rotation matrix. |
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.