ComputeDisplayTransformArgs Interface
Arguments supplied to computeDisplayTransform.
Properties
Name | Type | Description | |
---|---|---|---|
elementId | string | undefined | The Id of a specific element belonging to the model identified by modelId for which to compute the display transform. | |
modelId | string | The Id of the model for which to compute the display transform. | |
output | Transform | undefined | If supplied, computeDisplayTransform will modify and return this Transform to hold the result instead of allocating a new Transform. | |
timePoint | number | undefined | The point in time, expressed in Unix seconds, at which to evaluate the display transform. | |
viewAttachmentId | string | undefined | The element Id of the ViewAttachment through which the element or model is drawn. |
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.