AuxCoordSystemSpatialState Class
The state of an AuxCoordSystemSpatial element in the frontend
Extends
Methods
Name | Description | |
---|---|---|
constructor(props: AuxCoordSystem3dProps, iModel: IModelConnection): AuxCoordSystemSpatialState |
Inherited methods
Name | Inherited from | Description |
---|---|---|
clone(iModel?: IModelConnection): this Inherited | AuxCoordSystem3dState | Make an independent copy of this EntityState |
display(context: DecorateContext, options: ACSDisplayOptions): void Inherited | AuxCoordSystem3dState | |
drawGrid(context: DecorateContext): void Inherited | AuxCoordSystem3dState | |
equals(other: this): boolean Inherited | AuxCoordSystem3dState | Return true if this EntityState is equal to another one. |
getOrigin(result?: Point3d): Point3d Inherited | AuxCoordSystem3dState | |
getRotation(result?: Matrix3d): Matrix3d Inherited | AuxCoordSystem3dState | get a copy of the rotation matrix for this ACS. |
isValidForView(view: ViewState): boolean Inherited | AuxCoordSystem3dState | |
setOrigin(val: Readonly<WritableXYAndZ> | Readonly<WritableXAndY>): void Inherited | AuxCoordSystem3dState | |
setRotation(rMatrix: Matrix3d): void Inherited | AuxCoordSystem3dState | |
toJSON(): AuxCoordSystem3dProps Inherited | AuxCoordSystem3dState | Obtain this element's JSON representation. |
createNew(acsName: string, iModel: IModelConnection): AuxCoordSystemState Static Inherited | AuxCoordSystem3dState | Create a new AuxCoordSystemState. |
fromProps(props: AuxCoordSystemProps, iModel: IModelConnection): AuxCoordSystemState Static Inherited | AuxCoordSystem3dState | |
isOriginInView(drawOrigin: Point3d, viewport: Viewport, adjustOrigin: boolean): boolean Static Inherited | AuxCoordSystem3dState | Given an origin point, returns whether the point falls within the view or not. |
Properties
Name | Type | Description | |
---|---|---|---|
className Accessor Static ReadOnly | string | The name of the BIS class associated with this class. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Accessor Static Inherited ReadOnly | string | AuxCoordSystem3dState | Get full BIS class name of this Entity in the form "SchemaName:ClassName". |
classFullName Readonly Inherited | string | AuxCoordSystem3dState | The full class name in the form "schema:class". |
className Accessor Inherited ReadOnly | string | AuxCoordSystem3dState | The name of the BIS class associated with this class. |
code Readonly Inherited | Code | AuxCoordSystem3dState | The Code for this element |
description Inherited | string | undefined | AuxCoordSystem3dState | |
federationGuid Readonly Inherited | string | undefined | AuxCoordSystem3dState | A FederationGuid assigned to this element by some other federated database |
id Readonly Inherited | string | AuxCoordSystem3dState | The Id of this Entity. |
iModel Readonly Inherited | IModelConnection | AuxCoordSystem3dState | The iModel from which this Entity was loaded |
is3d Accessor Inherited ReadOnly | boolean | AuxCoordSystem3dState | |
jsonProperties Readonly Inherited | { T } | AuxCoordSystem3dState | Optional json properties of this Entity. |
model Readonly Inherited | string | AuxCoordSystem3dState | The ModelId of the Model containing this element |
origin Readonly Inherited | Point3d | AuxCoordSystem3dState | Origin of the AuxCoordSystem3d |
parent Readonly Inherited | RelatedElement | undefined | AuxCoordSystem3dState | The parent Element of this, or undefined if no parent. |
pitch Inherited | number | AuxCoordSystem3dState | Pitch angle |
roll Inherited | number | AuxCoordSystem3dState | Roll angle |
schemaName Accessor Static Inherited ReadOnly | string | AuxCoordSystem3dState | The name of the BIS schema for this class. |
type Inherited | number | AuxCoordSystem3dState | |
userLabel Readonly Inherited | string | undefined | AuxCoordSystem3dState | A user-assigned label for this element. |
yaw Inherited | number | AuxCoordSystem3dState | Yaw angle |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.