RealityTile Class

A Tile within a RealityTileTree, representing part of a reality model (e.g., a point cloud or photogrammetry mesh) or 3d terrain with map imagery.

Extends

Extended by

Inherited methods

Name Inherited from Description
computeVisibility(args: TileDrawArgs): TileVisibility Inherited Tile Determine the visibility of this tile according to the specified args.
countDescendants(): number Inherited Tile Primarily for debugging purposes, compute the number of tiles below this one in the TileTree.
dispose(): void Inherited Tile Dispose of resources held by this tile and all of its children, marking it and all of its children as "abandoned".
disposeChildren(): void Protected Inherited Tile Dispose of this tile's child tiles and mark them as "not loaded".
drawGraphics(args: TileDrawArgs): void Inherited Tile Output this tile's graphics.
isContentCulled(args: TileDrawArgs): boolean Protected Inherited Tile Returns true if this tile's content bounding volume is culled by the frustum or clip volumes specified by args.
isFrustumCulled(box: Frustum, args: TileDrawArgs, testClipIntersection: boolean, sphere?: BoundingSphere): boolean Protected Inherited Tile  
isRegionCulled(args: TileDrawArgs): boolean Protected Inherited Tile Returns true if this tile's bounding volume is culled by the frustum or clip volumes specified by args.
loadChildren(): TileTreeLoadStatus Protected Inherited Tile If this tile's child tiles have not yet been requested, enqueue an asynchronous request to load them.
meetsScreenSpaceError(args: TileDrawArgs): boolean Protected Inherited Tile Returns true if this tile is of at least high enough resolution to be displayed, per the supplied TileDrawArgs; or false if
setGraphic(graphic: RenderGraphic): void Protected Inherited Tile  
setIsReady(): void Inherited Tile  
setLeaf(): void Inherited Tile  
setNotFound(): void Inherited Tile  

Properties

Name Type Description
geometry Accessor ReadOnly undefined | RealityTileGeometry A representation of the tile's geometry.  

Inherited properties

Name Type Inherited from Description
_childrenLoadStatus Protected Inherited TileTreeLoadStatus Tile The current loading state of this tile's children.
_contentId Protected Inherited string Tile Uniquely identifies this tile's content in the context of its tree.
_contentRange Protected Inherited Range3d | undefined Tile A volume no larger than this tile's range, and optionally more tightly encompassing its contents, used for more accurate culling.
_graphic Protected Inherited RenderGraphic | undefined Tile This tile's renderable content.
_hadGraphics Protected Inherited boolean Tile True if this tile ever had graphics loaded.
_maximumSize Protected Inherited number Tile The maximum size in pixels this tile can be drawn.
boundingSphere Readonly Inherited BoundingSphere Tile The bounding sphere for this tile.
center Accessor Inherited ReadOnly Point3d Tile The point at the center of this tile's volume.
children Accessor Inherited ReadOnly undefined | Tile[] Tile This tile's child tiles, if they exist and are loaded. The children are fully contained within this tile's volume and provide higher-resolution graphics than this tile.
contentId Accessor Inherited ReadOnly string Tile Uniquely identifies this tile's content.
contentRange Accessor Inherited ReadOnly Range3d Tile A volume no larger than this tile's range, and optionally more tightly encompassing its contents, used for more accurate culling.
depth Readonly Inherited number Tile The depth of this tile within its TileTree.
hasContentRange Accessor Inherited ReadOnly boolean Tile True if this tile has a known volume tightly encompassing its graphics.
hasGraphics Accessor Inherited ReadOnly boolean Tile True if this tile has graphics ready to draw.
iModel Accessor Inherited ReadOnly IModelConnection Tile The IModelConnection to which this tile belongs.
isLeaf Accessor Inherited ReadOnly boolean Tile True if this tile has no child tiles.
isLoading Accessor Inherited ReadOnly boolean Tile True if this tile's content is currently being loaded.
isNotFound Accessor Inherited ReadOnly boolean Tile True if an attempt to load this tile's content failed.
isQueued Accessor Inherited ReadOnly boolean Tile True if a request for this tile's content has been enqueued.
isReady Accessor Inherited ReadOnly boolean Tile True if this tile's content has been loaded and is ready to be drawn.
loadStatus Accessor Inherited ReadOnly TileLoadStatus Tile Tile contents are loaded asynchronously on demand. This member tracks the current loading status of this tile's contents.
maximumSize Accessor Inherited ReadOnly number Tile The maximum size in pixels this tile can be drawn. If the size of the tile on screen exceeds this maximum, a higher-resolution tile should be drawn in its place.
parent Readonly Inherited undefined | Tile Tile The parent of this tile, or undefined if it is the TileTree's root tile.
radius Accessor Inherited ReadOnly number Tile The radius of a sphere fully encompassing this tile's volume - used for culling.
range Readonly Inherited Range3d Tile The volume of space occupied by this tile.
tree Readonly Inherited TileTree Tile The TileTree to which this tile belongs.
usageMarker Readonly Inherited TileUsageMarker Tile Tracks the usage of this tile.

Defined in

Last Updated: 14 November, 2024