TileLoadStatus Enumeration
Describes the current status of a Tile's content. Tile content is loaded via an asynchronous TileRequest.
@see loadStatus.
Members
Name |
Value |
Description |
Abandoned |
|
The tile has been disposed. |
Loading |
|
A response has been received and the tile's graphics and other data are being loaded on the frontend. |
NotFound |
|
A request to load the tile's contents failed. |
NotLoaded |
|
No attempt to load the tile's content has been made, or the tile has since been unloaded. It currently has no graphics. |
Queued |
|
A request has been dispatched to load the tile's contents, and a response is pending. |
Ready |
|
The tile has been loaded, and if the tile is displayable it has graphics. |
Defined in
Last Updated: 14 November, 2024