BoundingSphere Class
Describes a spherical volume of space as an approximation of the shape of some more complex geometric entity fully contained within that volume. When performing tests for intersection or containment, the approximation can be used as a first, quick check.
@see computeContainment, for example.
Methods
Name | Description | |
---|---|---|
constructor(center: Point3d..., radius: number0): BoundingSphere | Create a new bounding sphere with the specified center and radius. | |
init(center: Point3d, radius: number): void | Change the center and radius of the sphere. | |
transformBy(transform: Transform, result?: BoundingSphere): BoundingSphere | Applies the specified transformation matrix to produce a new bounding sphere. | |
transformInPlace(transform: Transform): void | Apply the specified transform to this bounding sphere. |
Properties
Name | Type | Description | |
---|---|---|---|
center | Point3d | The point at the center of the sphere. | |
radius | number | The radius of the sphere. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.