MaterialParams Interface
Describes a RenderMaterial.
@see createRenderMaterial to create a material.
Properties
Name | Type | Description | |
---|---|---|---|
alpha | number | undefined | Specifies the transparency of the material from 0.0 (fully transparent) to 1.0 (fully opaque). | |
diffuse | MaterialDiffuseProps | undefined | The diffuse properties of the material. | |
specular | MaterialSpecularProps | undefined | The specular properties of the material. | |
textureMapping | MaterialTextureMappingProps | undefined | Maps RenderTexture images to the surfaces to which the material is applied to customize their appearance. |
Defined in
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.