Instance Interface
Represents one repetition of a GraphicTemplate. Each Instance
draws the same graphics defined by the template, but with its own position, rotation, and/or scaling transform.
Each instance can optionally selectively override aspects of the template graphic's symbology and/or specify a feature that permits it to be interacted with
independently of any other instances.
@see RenderInstancesParamsBuilder to create a collection of Instance
s.
Properties
Name | Type | Description | |
---|---|---|---|
feature | string | Feature | Uniquely identifies the Feature that this instance represents. | |
symbology | InstanceSymbology | undefined | If present, specifies how to override aspects of the template's appearance, e.g., by changing its color. | |
transform | Transform | The translation, rotation, and/or scaling to apply to the template. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.