FormattedQuantityDescription Class

Base Quantity Property Description

Extends

Extended by

Methods

Name Description
constructor(name: string, displayLabel: string, iconSpec?: string): FormattedQuantityDescription    
formatValue(numberValue: number): string Protected    
parseString(userInput: string): ParseResults Protected    

Properties

Name Type Description
formatterQuantityType Accessor Abstract ReadOnly QuantityType    
formatterSpec Accessor ReadOnly undefined | FormatterSpec    
parseError Accessor Abstract ReadOnly string    
parserSpec Accessor ReadOnly undefined | ParserSpec    

Inherited properties

Name Type Inherited from Description
displayLabel Inherited string BaseQuantityDescription Display label for the property description
editor Inherited PropertyEditorInfo BaseQuantityDescription Information for a property editor
format Inherited (numberValue: number) => string BaseQuantityDescription  
name Inherited string BaseQuantityDescription Name of the property description
parse Inherited (userInput: string) => ParseResults BaseQuantityDescription  
typename Inherited string BaseQuantityDescription Type name used to determine applicable Type Converter and Property Editor

Defined in

Last Updated: 14 November, 2024