BaseQuantityDescription Class
Base Quantity Property Description
Implements
Methods
Name | Description | |
---|---|---|
constructor(name: string, displayLabel: string, iconSpec?: string): BaseQuantityDescription | ||
format(numberValue: number): string | ||
formatValue(numberValue: number): string Protected Abstract | ||
parse(userInput: string): ParseResults | ||
parseString(userInput: string): ParseResults Protected Abstract |
Properties
Name | Type | Description | |
---|---|---|---|
displayLabel | string | Display label for the property description | |
editor | PropertyEditorInfo | Information for a property editor | |
name | string | Name of the property description | |
parseError Accessor Abstract ReadOnly | string | ||
typename | string | Type name used to determine applicable Type Converter and Property Editor |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.