MapLayerSource Class

A source for map layers. These may be catalogued for convenient use by users or applications.

Methods

Name Description
collectQueryParams(): { T } Collect all query parameters  
toJSON(): Omit<MapLayerSourceProps, "formatId"> & { formatId: string }    
toLayerSettings(subLayers?: MapSubLayerProps[]): undefined | ImageMapLayerSettings    
validateSource(ignoreCache?: boolean): Promise<MapLayerSourceValidation>    
fromJSON(json: MapLayerSourceProps): undefined | MapLayerSource Static    

Properties

Name Type Description
baseMap boolean    
formatId string    
name string    
password string | undefined    
savedQueryParams { T } | undefined List of query parameters that will get appended to the source URL that should be be persisted part of the JSON representation.  
transparentBackground boolean | undefined    
unsavedQueryParams { T } | undefined List of query parameters that will get appended to the source URL that should not be be persisted part of the JSON representation.  
url string    
userName string | undefined    

Defined in

Last Updated: 14 November, 2024