MapLayerSourceProps Interface

JSON representation of a map layer source.

@see ImageryMapLayerFormatId

Properties

Name Type Description
baseMap boolean | undefined Indicate if this source definition should be used as a base map.  
formatId string | undefined Identifies the map layers source.  
name string Name  
queryParams { T } | undefined List of query parameters that will get appended to the source.  
transparentBackground boolean | undefined True to indicate background is transparent.  
url string URL of the source's endpoint.  

Defined in

Last Updated: 14 November, 2024