GeometryParams Class
Describes the display properties of graphics in a persistent element's GeometryStream that aren't inherited from SubCategoryAppearance.
@see GeometryStreamProps.
Methods
Name | Description | |
---|---|---|
constructor(categoryId: string, subCategoryId: stringId64.invalid): GeometryParams | Create a GeometryParams given a Category Id for a GeometricElement and optional SubCategory Id. | |
clone(): GeometryParams | ||
isEquivalent(other: GeometryParams): boolean | Compare two GeometryParams for equivalence, i.e. | |
resetAppearance(): void | Clears SubCategoryAppearance overrides while preserving categoryId and subCategoryId. | |
setCategoryId(categoryId: string, clearAppearanceOverrides: booleantrue): void | Change categoryId to the supplied id, subCategoryId to the supplied category's the default subCategory, and optionally clear any SubCategoryAppearance overrides. | |
setSubCategoryId(subCategoryId: string, clearAppearanceOverrides: booleantrue): void | Change subCategoryId to the supplied id and optionally clear any SubCategoryAppearance overrides. |
Properties
Name | Type | Description | |
---|---|---|---|
backgroundFill | BackgroundFill | undefined | Optional fill using the current view background color for region interiors. | |
categoryId | string | ||
elmPriority | number | undefined | Optional display priority added to priority. | |
elmTransparency | number | undefined | Optional line color transparency to combine with transparency. | |
fillColor | ColorDef | undefined | Optional fill color for region interiors. | |
fillDisplay | FillDisplay | undefined | Optional fill specification that determines when and if a region interior will display using gradient, backgroundFill, or fillColor in that order of preference. | |
fillTransparency | number | undefined | Optional fill color transparency to combine with transparency. | |
geometryClass | GeometryClass | undefined | Optional geometry classification that can be toggled off with a ViewFlags independent of invisible. | |
gradient | Gradient.Symb | undefined | Optional gradient fill settings for region interiors. | |
lineColor | ColorDef | undefined | Optional line color to override SubCategoryAppearance.color. | |
materialId | string | undefined | Optional render material to override materialId. | |
pattern | AreaPattern.Params | undefined | Optional area pattern settings for region interiors. | |
styleInfo | LineStyle.Info | undefined | Optional line style to override styleId plus modifiers to override the line style definition. | |
subCategoryId | string | ||
weight | number | undefined | Optional line weight to override SubCategoryAppearance.weight. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.