TextureMapping.ParamProps Interface
Properties used to construct a TextureMapping.Params.
Properties
Name | Type | Description | |
---|---|---|---|
constantLodProps | TextureMapping.ConstantLodParamProps | undefined | Parameters for constantLod mapping mode. | |
mapMode | TextureMapping.Mode | undefined | The mode by which to map the image to a surface. | |
textureMat2x3 | TextureMapping.Trans2x3 | undefined | The matrix used to map the image to a surface. | |
textureWeight | number | undefined | The ratio in [0, 1] with which to mix the color sampled from the texture with the surface's color. | |
useConstantLod | boolean | undefined | True if want to use constant LOD texture mapping for the surface texture. |
Defined in
- core/common/src/TextureMapping.ts Line 170
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.