RenderMaterial.Params Class
Deprecated in 3.x. Use CreateRenderMaterialArgs.
Methods
Name | Description | |
---|---|---|
constructor(key?: string): RenderMaterial.Params | ||
fromColors(key?: string, diffuseColor?: ColorDef, specularColor?: ColorDef, emissiveColor?: ColorDef, reflectColor?: ColorDef, textureMap?: TextureMapping): RenderMaterial.Params Static | Create a RenderMaterial params object using specified key and ColorDef values, as well as an optional texture mapping. |
Properties
Name | Type | Description | |
---|---|---|---|
alpha Accessor | undefined | number | A value from 0.0 (fully-transparent) to 1.0 (fully-opaque) controlling the transparency of surfaces to which this material is applied; | |
defaults Static Readonly | RenderMaterial.Params | Obtain an immutable instance of a RenderMaterial with all default properties. | |
diffuse | number | Diffuse weight in [0..1] | |
diffuseColor | ColorDef | undefined | Diffuse color, or undefined if this material does not override the surface's own color. | |
key | string | undefined | If the material originates from a Material element in the IModel, the Id of that element. | |
specular | number | Specular weight in [0..1] | |
specularColor | ColorDef | undefined | Specular color. | |
specularExponent | number | ||
textureMapping | TextureMapping | undefined | Optional pattern mapping applied to the surface. |
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.