getFeatureAppearance Method
Supply the desired appearance overrides for the specified Feature, or undefined
if the feature should not be drawn.
The feature is described by its components for efficiency reasons.
getFeatureAppearance(source: FeatureAppearanceSource, elemLo: number, elemHi: number, subcatLo: number, subcatHi: number, geomClass: GeometryClass, modelLo: number, modelHi: number, type: BatchType, animationNodeId: number): undefined | FeatureAppearance
@returns The desired appearance overrides, or undefined
to indicate the feature should not be displayed.
@see - getAppearance to forward the request to the source.
- Id64.isValidUint32Pair to determine if the components of an Id64String represent a valid Id.
Parameter | Type | Description |
---|---|---|
source | FeatureAppearanceSource | The base symbology overrides, e.g., typically defined by a Viewport. |
elemLo | number | The lower 32 bits of the feature's element Id. |
elemHi | number | The upper 32 bits of the feature's element Id. |
subcatLo | number | The lower 32 bits of the feature's subcategory Id. |
subcatHi | number | The upper 32 bits of the feature's subcategory Id. |
geomClass | GeometryClass | The geometry class of the feature. |
modelLo | number | The lower 32 bits of the feature's model Id. |
modelHi | number | The upper 32 bits of the feature's model Id. |
type | BatchType | The type of batch to which the feature belongs. |
animationNodeId | number | The Id of the corresponding node in the RenderSchedule, or 0 if none. |
Returns - undefined | FeatureAppearance
The desired appearance overrides, or undefined
to indicate the feature should not be displayed.
Defined in
- core/common/src/FeatureSymbology.ts Line 967
Last Updated: 13 November, 2024