fromGeometryPart MethodStatic
Create a new GeometryStream iterator for a GeometryPart. To iterate a part's GeometryStream in the context of a part instance found for a GeometricElement, provide the optional GeometryParams and Transform from the GeometricElement's GeometryStreamIterator. Supply the GeometryParams to return appearance information as inherited from the GeometricElement. Supply the partToWorld transform to return the part geometry in world coordinates. Supply the partToLocal transform to return the part geometry relative to the GeometricElement's placement.
fromGeometryPart(geomPart: Pick<GeometryPartProps, "geom">, geomParams?: GeometryParams, partTransform?: Transform): GeometryStreamIterator
@throws IModelError if geomPart.geom is undefined.
Parameter | Type | Description |
---|---|---|
geomPart | Pick<GeometryPartProps, "geom"> | |
geomParams | GeometryParams | |
partTransform | Transform |
Returns - GeometryStreamIterator
Defined in
Last Updated: 14 November, 2024