GeodeticTransform Class
This class represents a geodetic transformation that enables transforming longitude/latitude coordinates from one datum to another.
Implements
Methods
Name | Description | |
---|---|---|
constructor(data?: GeodeticTransformProps): GeodeticTransform | ||
equals(other: GeodeticTransform): boolean | Compares two geodetic Transforms. | |
toJSON(): GeodeticTransformProps | Creates a JSON from the Geodetic Transform definition | |
fromJSON(data: GeodeticTransformProps): GeodeticTransform Static | Creates a Geodetic Transform from JSON representation. |
Properties
Name | Type | Description | |
---|---|---|---|
geocentric Readonly | GeocentricTransform | undefined | When method is Geocentric this property contains the geocentric parameters | |
gridFile Readonly | GridFileTransform | undefined | When method is GridFiles this property contains the grid files parameters | |
method Readonly | GeodeticTransformMethod | The method used by the geodetic transform | |
positionalVector Readonly | PositionalVectorTransform | undefined | When method is PositionalVector this property contains the positional vector parameters | |
sourceDatumId Readonly | string | undefined | The id of the source datum. | |
sourceEllipsoid Readonly | GeodeticEllipsoid | undefined | The identifier of the source geodetic datum as stored in the dictionary or the service database. | |
targetDatumId Readonly | string | undefined | The id of the target datum. | |
targetEllipsoid Readonly | GeodeticEllipsoid | undefined | The complete definition of the target geodetic ellipsoid referred to by ellipsoidId. |
Defined in
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.