GeodeticTransformProps Interface
This interface represents a geodetic transformation that enables transforming longitude/latitude coordinates from one datum to another.
Implemented by
Properties
Name | Type | Description | |
---|---|---|---|
geocentric | GeocentricTransformProps | undefined | When method is Geocentric this property contains the geocentric parameters | |
gridFile | GridFileTransformProps | undefined | When method is GridFiles this property contains the grid files parameters | |
method | GeodeticTransformMethod | The method used by the geodetic transform | |
positionalVector | PositionalVectorTransformProps | undefined | When method is PositionalVector this property contains the positional vector parameters | |
sourceDatumId | string | undefined | The id of the source datum. | |
sourceEllipsoid | GeodeticEllipsoidProps | undefined | The complete definition of the source geodetic ellipsoid referred to by ellipsoidId. | |
targetDatumId | string | undefined | The id of the target datum. | |
targetEllipsoid | GeodeticEllipsoidProps | undefined | The complete definition of the target geodetic ellipsoid referred to by ellipsoidId. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.