GeocentricTransform Class
This class represents a geocentric (three parameters) geodetic transformation.
Implements
Methods
Name | Description | |
---|---|---|
constructor(data?: GeocentricTransformProps): GeocentricTransform | ||
equals(other: GeocentricTransform): boolean | Compares two geodetic transforms. | |
toJSON(): GeocentricTransformProps | Creates a JSON from the Geodetic GeocentricTransform definition | |
fromJSON(data: GeocentricTransformProps): GeocentricTransform Static | Creates a Geocentric Transform from JSON representation. |
Properties
Name | Type | Description | |
---|---|---|---|
delta Readonly | Vector3d | The frame translation components in meters |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.