GeodeticDatum Class
This class represents a geodetic datum. Geodetic datums are based on an ellipsoid. In addition to the ellipsoid definition they are the base for longitude/latitude coordinates. Geodetic datums are the basis for geodetic transformations. Most geodetic datums are defined by specifying the transformation to the common base WGS84 (or local equivalent). The transforms property can contain the definition of the transformation path to WGS84. Sometimes there exists transformation paths direct from one non-WGS84 datum to another non-WGS84. The current model does not allow specifications of these special paths at the moment.
Implements
Methods
Name | Description | |
---|---|---|
constructor(_data?: GeodeticDatumProps): GeodeticDatum | ||
equals(other: GeodeticDatum): boolean | Compares two Geodetic Datums. | |
toJSON(): GeodeticDatumProps | Creates a JSON from the Geodetic Datum definition | |
fromJSON(data: GeodeticDatumProps): GeodeticDatum Static | Creates a Geodetic Datum from JSON representation. |
Properties
Name | Type | Description | |
---|---|---|---|
additionalTransformPaths Readonly | GeodeticTransformPath[] | undefined | The optional list of transformation paths to other datum. | |
deprecated Readonly | boolean | If true then indicates the definition is deprecated. | |
description Readonly | string | undefined | Description | |
ellipsoid Readonly | GeodeticEllipsoid | undefined | The full definition of the geodetic ellipsoid associated to the datum. | |
ellipsoidId Readonly | string | undefined | The key name to the base Ellipsoid. | |
epsg Readonly | number | undefined | The EPSG code of the geodetic datum. | |
id Readonly | string | undefined | GeodeticDatum key name | |
source Readonly | string | undefined | A textual description of the source of the geodetic datum definition. | |
transforms Readonly | GeodeticTransform[] | undefined | The transformation to WGS84. |
Defined in
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.