GeodeticTransformPath Class
This class represents a geodetic datum transform path. It contains a list of transforms linking a source to a target geodetic datum.
Implements
Methods
Name | Description | |
---|---|---|
constructor(_data?: GeodeticTransformPathProps): GeodeticTransformPath | ||
equals(other: GeodeticTransformPath): boolean | Compares two Geodetic Transform Paths. | |
toJSON(): GeodeticTransformPathProps | Creates a JSON from the Geodetic transform path definition | |
fromJSON(data: GeodeticTransformPathProps): GeodeticTransformPath Static | Creates a Geodetic transform path from JSON representation. |
Properties
Name | Type | Description | |
---|---|---|---|
sourceDatumId Readonly | string | undefined | Source geodetic datum key name | |
targetDatumId Readonly | string | undefined | Target geodetic datum key name | |
transforms Readonly | GeodeticTransform[] | undefined | The transformation path from source datum to target datum. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.