ViewFlagProps Interface
JSON representation of ViewFlags. This is a persistence format with some unfortunate quirks that have been retained for backwards compatibility. In particular, it supplies three separate flags intended to control lighting - noCameraLights, noSourceLights, and noSolarLight - but there exists only a single lighting flag. lighting is set to true unless all three of the "no lighting" flags are true. It also uses awkward negative (noConstruct, noTransp) and/or abbreviated (clipVol, visEdges) property names that differ from those of the corresponding ViewFlags properties, making usage of this type in code error-prone. Prefer to use ViewFlagsProperties unless you need to work directly with the persistence format.
Properties
Name | Type | Description | |
---|---|---|---|
acs | boolean | undefined | If true, display graphics representing the AuxCoordSystem. | |
ambientOcclusion | boolean | undefined | If true, apply AmbientOcclusion. | |
backgroundMap | boolean | undefined | Display a background map. | |
clipVol | boolean | undefined | If true, apply the view's clipping volume. | |
forceSurfaceDiscard | boolean | undefined | Controls whether surface discard is always applied regardless of other ViewFlags. | |
grid | boolean | undefined | If true, display a grid in the view. | |
hidEdges | boolean | undefined | If true, display the edges of surfaces, even if they are behind other geometry. | |
monochrome | boolean | undefined | If true, apply the view's monochromeColor and monochromeMode to produce a monochrome image. | |
noCameraLights | boolean | undefined | See ViewFlagProps for how this affects lighting. | |
noConstruct | boolean | undefined | If true, don't display geometry of class Construction. | |
noDim | boolean | undefined | If true, don't display geometry of class Dimension. | |
noFill | boolean | undefined | If true, don't show filled planar regions, unless they use FillFlags.Always. | |
noMaterial | boolean | undefined | If true, don't apply RenderMaterials to surfaces. | |
noPattern | boolean | undefined | If true, don't display geometry of class Pattern. | |
noSolarLight | boolean | undefined | See ViewFlagProps for how this affects lighting. | |
noSourceLights | boolean | undefined | See ViewFlagProps for how this affects lighting. | |
noStyle | boolean | undefined | If true, don't apply LinePixels styles. | |
noTexture | boolean | undefined | If true, don't apply RenderTextures to surfaces. | |
noTransp | boolean | undefined | If true, display transparency geometry as opaque. | |
noWeight | boolean | undefined | If true, all lines are drawn with a width of 1 pixel. | |
noWhiteOnWhiteReversal | boolean | undefined | Disables the "white-on-white reversal" employed by some CAD applications. | |
renderMode | RenderMode | undefined | The basic rendering mode, which affects the behavior of other flags. | |
shadows | boolean | undefined | If true, display shadows. | |
thematicDisplay | boolean | undefined | If true, apply ThematicDisplay. | |
visEdges | boolean | undefined | If true, display the edges of surfaces. | |
wiremesh | boolean | undefined | If true, overlay surfaces with wiremesh to reveal their triangulation. |
Defined in
- core/common/src/ViewFlags.ts Line 55
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.