renderTimeline
Getter
The Id of a RenderTimeline element containing a RenderSchedule.Script used to animate the view. If scheduleScriptProps is defined, it takes precedence over the script supplied by the RenderTimeline.
renderTimeline: undefined | string
@note If this DisplayStyleSettings is associated with a DisplayStyleState, assigning to renderTimeline will enqueue asynchronous loading of
the script from the RenderTimeline element; for more readable code, prefer instead to await
DisplayStyleState.changeRenderTimeline.
@see onRenderTimelineChanged to be notified of changes to this property.
Returns - undefined | string
Setter
renderTimeline(id: string): void
Parameter | Type | Description |
---|---|---|
id | string |
Returns - void
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.