fork Method
Obtain the JSON representation of a new sequence that diverges from this sequence, with its initialLocalId set to this sequence's currentLocalId. The two sequences can generate Ids independently. Later, you can merge the sequences, resolving conflicts where the two sequences generated identical Ids. This is chiefly useful when generating transient Ids on a Worker.
fork(): TransientIdSequenceProps
Returns - TransientIdSequenceProps
Defined in
- core/bentley/src/Id.ts Line 778
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.