merge Method
Integrate the Ids generated by a fork of this sequence. All of the Ids generated by source
will be remapped to Ids at the end of this sequence.
This is chiefly useful when generating transient Ids on a Worker.
merge(source: TransientIdSequenceProps): (sourceLocalId: number) => number
@returns a function that permits you to remap the local Ids generated by source
into the corresponding local Ids assigned by this sequence.
@throws Error if source
is not a fork of this sequence or is malformed (e.g., contains negative and/or non-integer local Ids).
Parameter | Type | Description |
---|---|---|
source | TransientIdSequenceProps | The JSON representation of the forked sequence to be merged with this one. |
Returns - (sourceLocalId: number) => number
a function that permits you to remap the local Ids generated by source
into the corresponding local Ids assigned by this sequence.
Defined in
- core/bentley/src/Id.ts Line 791
Last Updated: 13 November, 2024