PhysicalModel Class
A container for persisting physical elements that model physical space.
@see PhysicalPartition
Extends
Methods
Name | Description | |
---|---|---|
constructor(props: GeometricModel3dProps, iModel: IModelDb): PhysicalModel Protected | ||
insert(iModelDb: IModelDb, parentSubjectId: string, name: string, isPlanProjection?: boolean): string Static | Insert a PhysicalPartition and a PhysicalModel that sub-models it. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected | SpatialModel | Collect the Ids of this entity's references at this level of the class hierarchy. |
delete(): void | SpatialModel | Delete this Model from the iModel. |
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void | SpatialModel | Call a function for each property of this Entity. |
getJsonProperty(name: string): any | SpatialModel | |
getReferenceIds(): EntityReferenceSet | SpatialModel | Get the set of this entity's entity references, EntityReferenceSet. |
getUserProperties(namespace: string): any | SpatialModel | Get a set of JSON user properties by namespace |
insert(): string | SpatialModel | Insert this Model in the iModel |
queryExtents(): Range3d | SpatialModel | Query for the union of the extents of the elements contained by this model. |
queryRange(): Promise<Range3d> | SpatialModel | Query for the union of the extents of all elements contained within this model. |
removeUserProperties(nameSpace: string): void | SpatialModel | Remove a set of JSON user properties, specified by namespace, from this Element |
setJsonProperty(name: string, value: any): void | SpatialModel | |
setUserProperties(nameSpace: string, value: any): void | SpatialModel | Change a set of user JSON properties of this Element by namespace. |
toJSON(): GeometricModel3dProps | SpatialModel | Obtain the JSON representation of this Entity. |
update(): void | SpatialModel | Update this Model in the iModel. |
is(otherClass: ): boolean Static | SpatialModel | return whether this Entity class is a subclass of another Entity class |
onDelete(arg: OnModelIdArg): void Protected Static | SpatialModel | Called before a Model is deleted. |
onDeleteElement(_arg: OnElementInModelIdArg): void Protected Static | SpatialModel | Called when an Element in an instance of a Model of this class is about to be deleted. |
onDeleted(_arg: OnModelIdArg): void Protected Static | SpatialModel | Called after a Model was deleted. |
onDeletedElement(_arg: OnElementInModelIdArg): void Protected Static | SpatialModel | Called after an Element in an instance of a Model of this class has been deleted. |
onInsert(arg: OnModelPropsArg): void Protected Static | SpatialModel | Called before a new Model is inserted. |
onInsertElement(_arg: OnElementInModelPropsArg): void Protected Static | SpatialModel | Called before a prospective Element is to be inserted into an instance of a Model of this class. |
onInserted(_arg: OnModelIdArg): void Protected Static | SpatialModel | Called after a new Model is inserted. |
onInsertedElement(_arg: OnElementInModelIdArg): void Protected Static | SpatialModel | Called after an Element has been inserted into an instance of a Model of this class. |
onUpdate(arg: OnModelPropsArg): void Protected Static | SpatialModel | Called before a Model is updated. |
onUpdateElement(_arg: OnElementInModelPropsArg): void Protected Static | SpatialModel | Called when an Element in an instance of a Model of this class is about to be updated. |
onUpdated(_arg: OnModelIdArg): void Protected Static | SpatialModel | Called after a Model is updated. |
onUpdatedElement(_arg: OnElementInModelIdArg): void Protected Static | SpatialModel | Called after an Element in an instance of a Model of this class has been updated. |
Properties
Name | Type | Description | |
---|---|---|---|
className Accessor Static ReadOnly | string | The name of the BIS class associated with this class. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Accessor ReadOnly | string | SpatialModel | Get the full BIS class name of this Entity in the form "schema:class". |
classFullName Accessor Static ReadOnly | string | SpatialModel | Get the full BIS class name of this Entity in the form "schema:class" |
className Accessor ReadOnly | string | SpatialModel | The name of the BIS class associated with this class. |
geometryGuid | string | undefined | SpatialModel | |
id | string | SpatialModel | The Id of this Entity. |
iModel | IModelDb | SpatialModel | The IModelDb that contains this Entity |
isInstanceOfEntity Readonly | "true" | SpatialModel | An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types |
isNotSpatiallyLocated Readonly | boolean | SpatialModel | If true, then the elements in this GeometricModel3d are not in real-world coordinates and will not be in the spatial index. |
isPlanProjection Readonly | boolean | SpatialModel | If true, then the elements in this GeometricModel3d are expected to be in an XY plane. |
isPrivate | boolean | SpatialModel | |
isSpatiallyLocated Accessor ReadOnly | boolean | SpatialModel | If true, then the elements in this GeometricModel3d are in real-world coordinates and will be in the spatial index. |
isTemplate | boolean | SpatialModel | |
jsonProperties Readonly | [key: string]: any | SpatialModel | |
modeledElement Readonly | RelatedElement | SpatialModel | |
name Readonly | string | SpatialModel | |
parentModel Readonly | string | SpatialModel | |
schema Static | SpatialModel | The Schema that defines this class. | |
schemaName Accessor ReadOnly | string | SpatialModel | The name of the BIS Schema that defines this class |
Defined in
- core/backend/src/Model.ts Line 337
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.