PhysicalMaterial Class

A PhysicalMaterial defines the matter that makes up physical elements.

@note See RenderMaterialElement for the DefinitionElement used to define rendering characteristics.

Extends

Extended by

Methods

Name Description
constructor(props: DefinitionElementProps, iModel: IModelDb): PhysicalMaterial Protected    
create<T extends PhysicalMaterial>(iModelDb: IModelDb, definitionModelId: string, name: string): T Static Create a PhysicalMaterial  
createCode(iModel: IModelDb, definitionModelId: string, name: string): Code Static Create a Code for a PhysicalMaterial given a name that is meant to be unique within the scope of the specified DefinitionModel.  

Inherited methods

Name Inherited from Description
collectPredecessorIds(predecessorIds: EntityReferenceSet): void Protected Inherited DefinitionElement Collect the Ids of this element's references at this level of the class hierarchy.
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected Inherited DefinitionElement Collect the Ids of this entity's references at this level of the class hierarchy.
delete(): void Inherited DefinitionElement Delete this Element from the iModel.
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited DefinitionElement Call a function for each property of this Entity.
DefinitionElement Get the class metadata for this element.
getDisplayLabel(): string Inherited DefinitionElement Get a display label for this Element.
getJsonProperty(nameSpace: string): any Inherited DefinitionElement Get a JSON property of this element, by namespace
getPredecessorIds(): Id64Set Inherited DefinitionElement Get the Ids of this element's references.
getReferenceIds(): EntityReferenceSet Inherited DefinitionElement Get the set of this entity's entity references, EntityReferenceSet.
getToolTipMessage(): string[] Inherited DefinitionElement Get a list of HTML strings that describe this Element for the tooltip.
getUserProperties(namespace: string): any Inherited DefinitionElement Get a set of JSON user properties by namespace
insert(): string Inherited DefinitionElement Insert this Element into the iModel.
removeUserProperties(nameSpace: string): void Inherited DefinitionElement Remove a set of JSON user properties, specified by namespace, from this Element
setJsonProperty(nameSpace: string, value: any): void Inherited DefinitionElement  
setUserProperties(nameSpace: string, value: any): void Inherited DefinitionElement Change a set of user JSON properties of this Element by namespace.
toJSON(): DefinitionElementProps Inherited DefinitionElement Obtain the JSON representation of this Entity.
update(): void Inherited DefinitionElement Update this Element in the iModel.
is(otherClass: ): boolean Static Inherited DefinitionElement return whether this Entity class is a subclass of another Entity class
onAllInputsHandled(_id: string, _iModel: IModelDb): void Protected Static Inherited DefinitionElement Called on an element in a graph after all of its inputs have been processed and before its outputs are processed.
onBeforeOutputsHandled(_id: string, _iModel: IModelDb): void Protected Static Inherited DefinitionElement Called when a root element in a subgraph is changed and before its outputs are processed.
onChildAdd(_arg: OnChildElementPropsArg): void Protected Static Inherited DefinitionElement Called when an existing element is about to be updated so that an instance of this class will become its new parent.
onChildAdded(_arg: OnChildElementIdArg): void Protected Static Inherited DefinitionElement Called after an existing element has been updated so that an instance of this class is its new parent.
onChildDelete(_arg: OnChildElementIdArg): void Protected Static Inherited DefinitionElement Called when an element with an instance of this class as its parent is about to be deleted.
onChildDeleted(_arg: OnChildElementIdArg): void Protected Static Inherited DefinitionElement Called after an element with an instance of this class as its parent was successfully deleted.
onChildDrop(_arg: OnChildElementIdArg): void Protected Static Inherited DefinitionElement Called when an element with an instance of this class as its parent is about to be updated change to a different parent.
onChildDropped(_arg: OnChildElementIdArg): void Protected Static Inherited DefinitionElement Called after an element with an instance of this class as its previous parent was updated to have a new parent.
onChildInsert(_arg: OnChildElementPropsArg): void Protected Static Inherited DefinitionElement Called when a new element with an instance of this class as its parent is about to be inserted.
onChildInserted(_arg: OnChildElementIdArg): void Protected Static Inherited DefinitionElement Called after a new element with an instance of this class as its parent was inserted.
onChildUpdate(_arg: OnChildElementPropsArg): void Protected Static Inherited DefinitionElement Called when an element with an instance of this class as its parent is about to be updated.
onChildUpdated(_arg: OnChildElementIdArg): void Protected Static Inherited DefinitionElement Called after an element with an instance of this the class as its parent was updated.
onCloned(_context: IModelElementCloneContext, _sourceProps: ElementProps, _targetProps: ElementProps): void Protected Static Inherited DefinitionElement Called during the iModel transformation process after an Element from the source iModel was cloned for the target iModel.
onDelete(arg: OnElementIdArg): void Protected Static Inherited DefinitionElement Called before an Element is deleted.
onDeleted(_arg: OnElementIdArg): void Protected Static Inherited DefinitionElement Called after an Element was deleted.
onInsert(arg: OnElementPropsArg): void Protected Static Inherited DefinitionElement Called before a new Element is inserted.
onInserted(arg: OnElementIdArg): void Protected Static Inherited DefinitionElement Called after a new Element was inserted.
onSubModelDelete(_arg: OnSubModelIdArg): void Protected Static Inherited DefinitionElement Called when a sub-model of an instance of this class is being deleted.
onSubModelDeleted(_arg: OnSubModelIdArg): void Protected Static Inherited DefinitionElement Called after a sub-model of an instance of this class was deleted.
onSubModelInsert(_arg: OnSubModelPropsArg): void Protected Static Inherited DefinitionElement Called when an instance of this class is being sub-modeled by a new Model.
onSubModelInserted(_arg: OnSubModelIdArg): void Protected Static Inherited DefinitionElement Called after an instance of this class was sub-modeled by a new Model.
onUpdate(arg: OnElementPropsArg): void Protected Static Inherited DefinitionElement Called before an Element is updated.
onUpdated(_arg: OnElementIdArg): void Protected Static Inherited DefinitionElement Called after an Element was updated.

Properties

Name Type Description
className Accessor Static ReadOnly string The name of the BIS class associated with this class.  

Inherited properties

Name Type Inherited from Description
classFullName Accessor Inherited ReadOnly string DefinitionElement Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor Static Inherited ReadOnly string DefinitionElement Get the full BIS class name of this Entity in the form "schema:class"
className Accessor Inherited ReadOnly string DefinitionElement The name of the BIS class associated with this class.
code Inherited Code DefinitionElement The Code for this element
federationGuid Inherited string | undefined DefinitionElement A FederationGuid assigned to this element by some other federated database
id Inherited string DefinitionElement The Id of this Entity.
iModel Inherited IModelDb DefinitionElement The IModelDb that contains this Entity
isInstanceOfEntity Readonly Inherited "true" DefinitionElement An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types
isPrivate Inherited boolean DefinitionElement If true, don't show this DefinitionElement in user interface lists.
jsonProperties Readonly Inherited { T } DefinitionElement Optional json properties of this element.
model Readonly Inherited string DefinitionElement The ModelId of the Model containing this element
parent Inherited RelatedElement | undefined DefinitionElement The parent element, if present, of this element.
requiredReferenceKeys Static Readonly Inherited ReadonlyArray DefinitionElement A required reference is an element that had to be inserted before this element could have been inserted.
schema Static Inherited DefinitionElement The Schema that defines this class.
schemaName Accessor Inherited ReadOnly string DefinitionElement The name of the BIS Schema that defines this class
userLabel Inherited string | undefined DefinitionElement A user-assigned label for this element.

Defined in

Last Updated: 14 November, 2024