GenericGraphicalType2d Class

The Generic:GraphicalType2d class is used when graphical types cannot be further classified.

@note More-specific BisCore:GraphicalType2d subclasses should be used wherever possible.

Extends

Methods

Name Description
constructor(props: TypeDefinitionElementProps, iModel: IModelDb): GenericGraphicalType2d    

Inherited methods

Name Inherited from Description
collectPredecessorIds(predecessorIds: EntityReferenceSet): void Protected Inherited GraphicalType2d Collect the Ids of this element's references at this level of the class hierarchy.
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected Inherited GraphicalType2d Collect the Ids of this entity's references at this level of the class hierarchy.
delete(): void Inherited GraphicalType2d Delete this Element from the iModel.
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited GraphicalType2d Call a function for each property of this Entity.
GraphicalType2d Get the class metadata for this element.
getDisplayLabel(): string Inherited GraphicalType2d Get a display label for this Element.
getJsonProperty(nameSpace: string): any Inherited GraphicalType2d Get a JSON property of this element, by namespace
getPredecessorIds(): Id64Set Inherited GraphicalType2d Get the Ids of this element's references.
getReferenceIds(): EntityReferenceSet Inherited GraphicalType2d Get the set of this entity's entity references, EntityReferenceSet.
getToolTipMessage(): string[] Inherited GraphicalType2d Get a list of HTML strings that describe this Element for the tooltip.
getUserProperties(namespace: string): any Inherited GraphicalType2d Get a set of JSON user properties by namespace
insert(): string Inherited GraphicalType2d Insert this Element into the iModel.
removeUserProperties(nameSpace: string): void Inherited GraphicalType2d Remove a set of JSON user properties, specified by namespace, from this Element
setJsonProperty(nameSpace: string, value: any): void Inherited GraphicalType2d  
setUserProperties(nameSpace: string, value: any): void Inherited GraphicalType2d Change a set of user JSON properties of this Element by namespace.
toJSON(): DefinitionElementProps Inherited GraphicalType2d Obtain the JSON representation of this Entity.
update(): void Inherited GraphicalType2d Update this Element in the iModel.
createCode(iModel: IModelDb, scopeModelId: string, codeValue: string): Code Static Inherited GraphicalType2d Create a Code for a GraphicalType2d element given a name that is meant to be unique within the scope of the specified DefinitionModel.
is(otherClass: ): boolean Static Inherited GraphicalType2d return whether this Entity class is a subclass of another Entity class
onAllInputsHandled(_id: string, _iModel: IModelDb): void Protected Static Inherited GraphicalType2d Called on an element in a graph after all of its inputs have been processed and before its outputs are processed.
onBeforeOutputsHandled(_id: string, _iModel: IModelDb): void Protected Static Inherited GraphicalType2d Called when a root element in a subgraph is changed and before its outputs are processed.
onChildAdd(_arg: OnChildElementPropsArg): void Protected Static Inherited GraphicalType2d Called when an existing element is about to be updated so that an instance of this class will become its new parent.
onChildAdded(_arg: OnChildElementIdArg): void Protected Static Inherited GraphicalType2d Called after an existing element has been updated so that an instance of this class is its new parent.
onChildDelete(_arg: OnChildElementIdArg): void Protected Static Inherited GraphicalType2d Called when an element with an instance of this class as its parent is about to be deleted.
onChildDeleted(_arg: OnChildElementIdArg): void Protected Static Inherited GraphicalType2d Called after an element with an instance of this class as its parent was successfully deleted.
onChildDrop(_arg: OnChildElementIdArg): void Protected Static Inherited GraphicalType2d Called when an element with an instance of this class as its parent is about to be updated change to a different parent.
onChildDropped(_arg: OnChildElementIdArg): void Protected Static Inherited GraphicalType2d Called after an element with an instance of this class as its previous parent was updated to have a new parent.
onChildInsert(_arg: OnChildElementPropsArg): void Protected Static Inherited GraphicalType2d Called when a new element with an instance of this class as its parent is about to be inserted.
onChildInserted(_arg: OnChildElementIdArg): void Protected Static Inherited GraphicalType2d Called after a new element with an instance of this class as its parent was inserted.
onChildUpdate(_arg: OnChildElementPropsArg): void Protected Static Inherited GraphicalType2d Called when an element with an instance of this class as its parent is about to be updated.
onChildUpdated(_arg: OnChildElementIdArg): void Protected Static Inherited GraphicalType2d Called after an element with an instance of this the class as its parent was updated.
onCloned(_context: IModelElementCloneContext, _sourceProps: ElementProps, _targetProps: ElementProps): void Protected Static Inherited GraphicalType2d Called during the iModel transformation process after an Element from the source iModel was cloned for the target iModel.
onDelete(arg: OnElementIdArg): void Protected Static Inherited GraphicalType2d Called before an Element is deleted.
onDeleted(_arg: OnElementIdArg): void Protected Static Inherited GraphicalType2d Called after an Element was deleted.
onInsert(arg: OnElementPropsArg): void Protected Static Inherited GraphicalType2d Called before a new Element is inserted.
onInserted(arg: OnElementIdArg): void Protected Static Inherited GraphicalType2d Called after a new Element was inserted.
onSubModelDelete(_arg: OnSubModelIdArg): void Protected Static Inherited GraphicalType2d Called when a sub-model of an instance of this class is being deleted.
onSubModelDeleted(_arg: OnSubModelIdArg): void Protected Static Inherited GraphicalType2d Called after a sub-model of an instance of this class was deleted.
onSubModelInsert(_arg: OnSubModelPropsArg): void Protected Static Inherited GraphicalType2d Called when an instance of this class is being sub-modeled by a new Model.
onSubModelInserted(_arg: OnSubModelIdArg): void Protected Static Inherited GraphicalType2d Called after an instance of this class was sub-modeled by a new Model.
onUpdate(arg: OnElementPropsArg): void Protected Static Inherited GraphicalType2d Called before an Element is updated.
onUpdated(_arg: OnElementIdArg): void Protected Static Inherited GraphicalType2d Called after an Element was updated.

Properties

Name Type Description
className Accessor Static ReadOnly string The name of the BIS class associated with this class.  

Inherited properties

Name Type Inherited from Description
classFullName Accessor Inherited ReadOnly string GraphicalType2d Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor Static Inherited ReadOnly string GraphicalType2d Get the full BIS class name of this Entity in the form "schema:class"
className Accessor Inherited ReadOnly string GraphicalType2d The name of the BIS class associated with this class.
code Inherited Code GraphicalType2d The Code for this element
federationGuid Inherited string | undefined GraphicalType2d A FederationGuid assigned to this element by some other federated database
id Inherited string GraphicalType2d The Id of this Entity.
iModel Inherited IModelDb GraphicalType2d The IModelDb that contains this Entity
isInstanceOfEntity Readonly Inherited "true" GraphicalType2d An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types
isPrivate Inherited boolean GraphicalType2d If true, don't show this DefinitionElement in user interface lists.
jsonProperties Readonly Inherited { T } GraphicalType2d Optional json properties of this element.
model Readonly Inherited string GraphicalType2d The ModelId of the Model containing this element
parent Inherited RelatedElement | undefined GraphicalType2d The parent element, if present, of this element.
recipe Inherited RelatedElement | undefined GraphicalType2d  
requiredReferenceKeys Static Readonly Inherited ReadonlyArray GraphicalType2d A required reference is an element that had to be inserted before this element could have been inserted.
schema Static Inherited GraphicalType2d The Schema that defines this class.
schemaName Accessor Inherited ReadOnly string GraphicalType2d The name of the BIS Schema that defines this class
userLabel Inherited string | undefined GraphicalType2d A user-assigned label for this element.

Defined in

Last Updated: 14 November, 2024