ExternalSourceGroup Class
A group of ExternalSources that are collectively a source of information for one or more elements.
@note The associated ECClass was added to the BisCore schema in version 1.0.13
Extends
Methods
Name | Description | |
---|---|---|
constructor(props: ExternalSourceProps, iModel: IModelDb): ExternalSourceGroup Protected |
Inherited methods
Name | Inherited from | Description |
---|---|---|
collectPredecessorIds(predecessorIds: EntityReferenceSet): void Protected Inherited | ExternalSource | Collect the Ids of this element's references at this level of the class hierarchy. |
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected Inherited | ExternalSource | |
delete(): void Inherited | ExternalSource | Delete this Element from the iModel. |
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited | ExternalSource | Call a function for each property of this Entity. |
getClassMetaData(): undefined | EntityMetaData Inherited | ExternalSource | Get the class metadata for this element. |
getDisplayLabel(): string Inherited | ExternalSource | Get a display label for this Element. |
getJsonProperty(nameSpace: string): any Inherited | ExternalSource | Get a JSON property of this element, by namespace |
getPredecessorIds(): Id64Set Inherited | ExternalSource | Get the Ids of this element's references. |
getReferenceIds(): EntityReferenceSet Inherited | ExternalSource | Get the set of this entity's entity references, EntityReferenceSet. |
ExternalSource | Get a list of HTML strings that describe this Element for the tooltip. | |
getUserProperties(namespace: string): any Inherited | ExternalSource | Get a set of JSON user properties by namespace |
insert(): string Inherited | ExternalSource | Insert this Element into the iModel. |
removeUserProperties(nameSpace: string): void Inherited | ExternalSource | Remove a set of JSON user properties, specified by namespace, from this Element |
setJsonProperty(nameSpace: string, value: any): void Inherited | ExternalSource | |
setUserProperties(nameSpace: string, value: any): void Inherited | ExternalSource | Change a set of user JSON properties of this Element by namespace. |
toJSON(): ExternalSourceProps Inherited | ExternalSource | |
update(): void Inherited | ExternalSource | Update this Element in the iModel. |
createCode(iModelDb: IModelDb, codeValue: string): Code Static Inherited | ExternalSource | Create a Code for an ExternalSource element given a name that is meant to be unique within the scope of the iModel. |
ensureCodeSpec(iModelDb: IModelDb): string Static Inherited | ExternalSource | The CodeSpec for ExternalSource elements is not automatically created, so this method ensures that it exists. |
is(otherClass: ): boolean Static Inherited | ExternalSource | return whether this Entity class is a subclass of another Entity class |
onAllInputsHandled(_id: string, _iModel: IModelDb): void Protected Static Inherited | ExternalSource | Called on an element in a graph after all of its inputs have been processed and before its outputs are processed. |
onBeforeOutputsHandled(_id: string, _iModel: IModelDb): void Protected Static Inherited | ExternalSource | Called when a root element in a subgraph is changed and before its outputs are processed. |
onChildAdd(_arg: OnChildElementPropsArg): void Protected Static Inherited | ExternalSource | Called when an existing element is about to be updated so that an instance of this class will become its new parent. |
onChildAdded(_arg: OnChildElementIdArg): void Protected Static Inherited | ExternalSource | Called after an existing element has been updated so that an instance of this class is its new parent. |
onChildDelete(_arg: OnChildElementIdArg): void Protected Static Inherited | ExternalSource | Called when an element with an instance of this class as its parent is about to be deleted. |
onChildDeleted(_arg: OnChildElementIdArg): void Protected Static Inherited | ExternalSource | Called after an element with an instance of this class as its parent was successfully deleted. |
onChildDrop(_arg: OnChildElementIdArg): void Protected Static Inherited | ExternalSource | Called when an element with an instance of this class as its parent is about to be updated change to a different parent. |
onChildDropped(_arg: OnChildElementIdArg): void Protected Static Inherited | ExternalSource | Called after an element with an instance of this class as its previous parent was updated to have a new parent. |
onChildInsert(_arg: OnChildElementPropsArg): void Protected Static Inherited | ExternalSource | Called when a new element with an instance of this class as its parent is about to be inserted. |
onChildInserted(_arg: OnChildElementIdArg): void Protected Static Inherited | ExternalSource | Called after a new element with an instance of this class as its parent was inserted. |
onChildUpdate(_arg: OnChildElementPropsArg): void Protected Static Inherited | ExternalSource | Called when an element with an instance of this class as its parent is about to be updated. |
onChildUpdated(_arg: OnChildElementIdArg): void Protected Static Inherited | ExternalSource | Called after an element with an instance of this the class as its parent was updated. |
onCloned(_context: IModelElementCloneContext, _sourceProps: ElementProps, _targetProps: ElementProps): void Protected Static Inherited | ExternalSource | Called during the iModel transformation process after an Element from the source iModel was cloned for the target iModel. |
onDelete(arg: OnElementIdArg): void Protected Static Inherited | ExternalSource | Called before an Element is deleted. |
onDeleted(_arg: OnElementIdArg): void Protected Static Inherited | ExternalSource | Called after an Element was deleted. |
onInsert(arg: OnElementPropsArg): void Protected Static Inherited | ExternalSource | Called before a new Element is inserted. |
onInserted(arg: OnElementIdArg): void Protected Static Inherited | ExternalSource | Called after a new Element was inserted. |
onSubModelDelete(_arg: OnSubModelIdArg): void Protected Static Inherited | ExternalSource | Called when a sub-model of an instance of this class is being deleted. |
onSubModelDeleted(_arg: OnSubModelIdArg): void Protected Static Inherited | ExternalSource | Called after a sub-model of an instance of this class was deleted. |
onSubModelInsert(_arg: OnSubModelPropsArg): void Protected Static Inherited | ExternalSource | Called when an instance of this class is being sub-modeled by a new Model. |
onSubModelInserted(_arg: OnSubModelIdArg): void Protected Static Inherited | ExternalSource | Called after an instance of this class was sub-modeled by a new Model. |
onUpdate(arg: OnElementPropsArg): void Protected Static Inherited | ExternalSource | Called before an Element is updated. |
onUpdated(_arg: OnElementIdArg): void Protected Static Inherited | ExternalSource | Called after an Element was updated. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Accessor Inherited ReadOnly | string | ExternalSource | Get the full BIS class name of this Entity in the form "schema:class". |
classFullName Accessor Static Inherited ReadOnly | string | ExternalSource | Get the full BIS class name of this Entity in the form "schema:class" |
className Accessor Inherited ReadOnly | string | ExternalSource | The name of the BIS class associated with this class. |
code Inherited | Code | ExternalSource | The Code for this element |
connectorName Inherited | string | undefined | ExternalSource | The name of the iModel Connecter that processed this ExternalSource. |
connectorVersion Inherited | string | undefined | ExternalSource | The version of the iModel Connecter that processed this ExternalSource. |
federationGuid Inherited | string | undefined | ExternalSource | A FederationGuid assigned to this element by some other federated database |
id Inherited | string | ExternalSource | The Id of this Entity. |
iModel Inherited | IModelDb | ExternalSource | The IModelDb that contains this Entity |
isInstanceOfEntity Readonly Inherited | "true" | ExternalSource | An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types |
jsonProperties Readonly Inherited | { T } | ExternalSource | Optional json properties of this element. |
model Readonly Inherited | string | ExternalSource | The ModelId of the Model containing this element |
parent Inherited | RelatedElement | undefined | ExternalSource | The parent element, if present, of this element. |
repository Inherited | ExternalSourceIsInRepository | undefined | ExternalSource | The repository that contains this ExternalSource. |
requiredReferenceKeys Static Readonly Inherited | ReadonlyArray |
ExternalSource | A required reference is an element that had to be inserted before this element could have been inserted. |
schema Static Inherited | ExternalSource | The Schema that defines this class. | |
schemaName Accessor Inherited ReadOnly | string | ExternalSource | The name of the BIS Schema that defines this class |
userLabel Inherited | string | undefined | ExternalSource | A user-assigned label for this element. |
Defined in
- core/backend/src/ExternalSource.ts Line 131
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.