DefinitionGroup Class
A non-exclusive set of DefinitionElements grouped using the DefinitionGroupGroupsDefinitions relationship.
@note The associated ECClass was added to the BisCore schema in version 1.0.10
Extends
Methods
Name | Description | |
---|---|---|
constructor(props: DefinitionElementProps, iModel: IModelDb): DefinitionGroup Protected | ||
create(iModelDb: IModelDb, definitionModelId: string, code: Code, isPrivate?: boolean): DefinitionGroup Static | Create a DefinitionGroup |
Inherited methods
Name | Inherited from | Description |
---|---|---|
collectPredecessorIds(predecessorIds: EntityReferenceSet): void Protected Inherited | DefinitionSet | Collect the Ids of this element's references at this level of the class hierarchy. |
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected Inherited | DefinitionSet | Collect the Ids of this entity's references at this level of the class hierarchy. |
delete(): void Inherited | DefinitionSet | Delete this Element from the iModel. |
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited | DefinitionSet | Call a function for each property of this Entity. |
getClassMetaData(): undefined | EntityMetaData Inherited | DefinitionSet | Get the class metadata for this element. |
getDisplayLabel(): string Inherited | DefinitionSet | Get a display label for this Element. |
getJsonProperty(nameSpace: string): any Inherited | DefinitionSet | Get a JSON property of this element, by namespace |
getPredecessorIds(): Id64Set Inherited | DefinitionSet | Get the Ids of this element's references. |
getReferenceIds(): EntityReferenceSet Inherited | DefinitionSet | Get the set of this entity's entity references, EntityReferenceSet. |
DefinitionSet | Get a list of HTML strings that describe this Element for the tooltip. | |
getUserProperties(namespace: string): any Inherited | DefinitionSet | Get a set of JSON user properties by namespace |
insert(): string Inherited | DefinitionSet | Insert this Element into the iModel. |
removeUserProperties(nameSpace: string): void Inherited | DefinitionSet | Remove a set of JSON user properties, specified by namespace, from this Element |
setJsonProperty(nameSpace: string, value: any): void Inherited | DefinitionSet | |
setUserProperties(nameSpace: string, value: any): void Inherited | DefinitionSet | Change a set of user JSON properties of this Element by namespace. |
toJSON(): DefinitionElementProps Inherited | DefinitionSet | Obtain the JSON representation of this Entity. |
update(): void Inherited | DefinitionSet | Update this Element in the iModel. |
is(otherClass: ): boolean Static Inherited | DefinitionSet | return whether this Entity class is a subclass of another Entity class |
onAllInputsHandled(_id: string, _iModel: IModelDb): void Protected Static Inherited | DefinitionSet | Called on an element in a graph after all of its inputs have been processed and before its outputs are processed. |
onBeforeOutputsHandled(_id: string, _iModel: IModelDb): void Protected Static Inherited | DefinitionSet | Called when a root element in a subgraph is changed and before its outputs are processed. |
onChildAdd(_arg: OnChildElementPropsArg): void Protected Static Inherited | DefinitionSet | Called when an existing element is about to be updated so that an instance of this class will become its new parent. |
onChildAdded(_arg: OnChildElementIdArg): void Protected Static Inherited | DefinitionSet | Called after an existing element has been updated so that an instance of this class is its new parent. |
onChildDelete(_arg: OnChildElementIdArg): void Protected Static Inherited | DefinitionSet | Called when an element with an instance of this class as its parent is about to be deleted. |
onChildDeleted(_arg: OnChildElementIdArg): void Protected Static Inherited | DefinitionSet | Called after an element with an instance of this class as its parent was successfully deleted. |
onChildDrop(_arg: OnChildElementIdArg): void Protected Static Inherited | DefinitionSet | Called when an element with an instance of this class as its parent is about to be updated change to a different parent. |
onChildDropped(_arg: OnChildElementIdArg): void Protected Static Inherited | DefinitionSet | Called after an element with an instance of this class as its previous parent was updated to have a new parent. |
onChildInsert(_arg: OnChildElementPropsArg): void Protected Static Inherited | DefinitionSet | Called when a new element with an instance of this class as its parent is about to be inserted. |
onChildInserted(_arg: OnChildElementIdArg): void Protected Static Inherited | DefinitionSet | Called after a new element with an instance of this class as its parent was inserted. |
onChildUpdate(_arg: OnChildElementPropsArg): void Protected Static Inherited | DefinitionSet | Called when an element with an instance of this class as its parent is about to be updated. |
onChildUpdated(_arg: OnChildElementIdArg): void Protected Static Inherited | DefinitionSet | Called after an element with an instance of this the class as its parent was updated. |
onCloned(_context: IModelElementCloneContext, _sourceProps: ElementProps, _targetProps: ElementProps): void Protected Static Inherited | DefinitionSet | Called during the iModel transformation process after an Element from the source iModel was cloned for the target iModel. |
onDelete(arg: OnElementIdArg): void Protected Static Inherited | DefinitionSet | Called before an Element is deleted. |
onDeleted(_arg: OnElementIdArg): void Protected Static Inherited | DefinitionSet | Called after an Element was deleted. |
onInsert(arg: OnElementPropsArg): void Protected Static Inherited | DefinitionSet | Called before a new Element is inserted. |
onInserted(arg: OnElementIdArg): void Protected Static Inherited | DefinitionSet | Called after a new Element was inserted. |
onSubModelDelete(_arg: OnSubModelIdArg): void Protected Static Inherited | DefinitionSet | Called when a sub-model of an instance of this class is being deleted. |
onSubModelDeleted(_arg: OnSubModelIdArg): void Protected Static Inherited | DefinitionSet | Called after a sub-model of an instance of this class was deleted. |
onSubModelInsert(_arg: OnSubModelPropsArg): void Protected Static Inherited | DefinitionSet | Called when an instance of this class is being sub-modeled by a new Model. |
onSubModelInserted(_arg: OnSubModelIdArg): void Protected Static Inherited | DefinitionSet | Called after an instance of this class was sub-modeled by a new Model. |
onUpdate(arg: OnElementPropsArg): void Protected Static Inherited | DefinitionSet | Called before an Element is updated. |
onUpdated(_arg: OnElementIdArg): void Protected Static Inherited | DefinitionSet | Called after an Element was updated. |
Properties
Name | Type | Description | |
---|---|---|---|
className Accessor Static ReadOnly | string | The name of the BIS class associated with this class. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Accessor Inherited ReadOnly | string | DefinitionSet | Get the full BIS class name of this Entity in the form "schema:class". |
classFullName Accessor Static Inherited ReadOnly | string | DefinitionSet | Get the full BIS class name of this Entity in the form "schema:class" |
className Accessor Inherited ReadOnly | string | DefinitionSet | The name of the BIS class associated with this class. |
code Inherited | Code | DefinitionSet | The Code for this element |
federationGuid Inherited | string | undefined | DefinitionSet | A FederationGuid assigned to this element by some other federated database |
id Inherited | string | DefinitionSet | The Id of this Entity. |
iModel Inherited | IModelDb | DefinitionSet | The IModelDb that contains this Entity |
isInstanceOfEntity Readonly Inherited | "true" | DefinitionSet | An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types |
isPrivate Inherited | boolean | DefinitionSet | If true, don't show this DefinitionElement in user interface lists. |
jsonProperties Readonly Inherited | { T } | DefinitionSet | Optional json properties of this element. |
model Readonly Inherited | string | DefinitionSet | The ModelId of the Model containing this element |
parent Inherited | RelatedElement | undefined | DefinitionSet | The parent element, if present, of this element. |
requiredReferenceKeys Static Readonly Inherited | ReadonlyArray |
DefinitionSet | A required reference is an element that had to be inserted before this element could have been inserted. |
schema Static Inherited | DefinitionSet | The Schema that defines this class. | |
schemaName Accessor Inherited ReadOnly | string | DefinitionSet | The name of the BIS Schema that defines this class |
userLabel Inherited | string | undefined | DefinitionSet | A user-assigned label for this element. |
Defined in
- core/backend/src/Element.ts Line 1027
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.