ImageCheckBoxEditor Class

ImageCheckBoxEditor Boolean editor that renders with an image instead of checkbox

Extends

Implements

Methods

Name Description
componentDidMount(): void    
componentDidUpdate(prevProps: PropertyEditorProps): void    
componentWillUnmount(): void    
getPropertyValue(): Promise<undefined | PropertyValue>    
render(): React.JSX.Element    

Properties

Name Type Description
hasFocus Accessor ReadOnly boolean    
htmlElement Accessor ReadOnly "null" | HTMLElement    
state Readonly Readonly<ImageCheckBoxEditorState>    

Defined in

Last Updated: 14 November, 2024