PropertyEditorProps Interface
Properties for a property editor component
Extends
Properties
Name | Type | Description | |
---|---|---|---|
onBlur | (event: React.FocusEvent<Element, Element>) => void | undefined | Handler for blur | |
onCancel | () => void | undefined | Handler for cancel | |
onCommit | (args: PropertyUpdatedArgs) => void | undefined | Handler for commit | |
propertyRecord | PropertyRecord | undefined | The property being updated. | |
setFocus | boolean | undefined | Indicates whether the Property Editor should set focus |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | string | undefined | CommonProps | Custom CSS class name |
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
style | React.CSSProperties | undefined | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.