FrontstageDef Class
FrontstageDef class provides an API for a Frontstage.
Methods
Name | Description | |
---|---|---|
constructor(): FrontstageDef | ||
_onActivated(): Promise<void> Protected | Handles when the Frontstage becomes activated | |
_onDeactivated(): Promise<void> Protected | Handles when the Frontstage becomes inactive | |
_onFrontstageReady(): void Protected | Handles when the Frontstage becomes active | |
addFloatingContentControl(contentControl?: ContentControl): void | Deprecated | |
dockWidgetContainer(widgetId: string): void | Finds the container with the specified widget and re-docks all widgets | |
dropFloatingContentControl(contentControl?: ContentControl): void | Deprecated | |
findWidgetDef(id: string): undefined | WidgetDef | Finds a WidgetDef based on a given id | |
floatWidget(widgetId: string, position?: Readonly<WritableXAndY>, size?: SizeProps): void | Create a new floating panel that contains the widget specified by its Id. | |
getFloatingWidgetContainerBounds(floatingWidgetId: string): undefined | RectangleProps | ||
getFloatingWidgetContainerIdByWidgetId(widgetId: string): undefined | string | ||
getFloatingWidgetContainerIds(): string[] | ||
getStagePanelDef(location: StagePanelLocation): undefined | StagePanelDef | Gets a StagePanelDef based on a given panel location | |
isFloatingWidget(widgetId: string): boolean | ||
isPopoutWidget(widgetId: string): boolean | ||
isWidgetDisplayed(widgetId: string): boolean | Check widget and panel state to determine whether the widget is currently displayed | |
onActivated(): Promise<void> | Handles when the Frontstage becomes activated | |
onDeactivated(): Promise<void> | Handles when the Frontstage becomes inactive | |
onFrontstageReady(): void | Handles when the Frontstage becomes active | |
popoutWidget(widgetId: string, position?: Readonly<WritableXAndY>, size?: SizeProps): void | Create a new popout/child window that contains the widget specified by its Id. | |
restoreLayout(): void | Restores frontstage layout to initial configuration. | |
setActiveContent(): Promise<boolean> | Sets the active view content to the default or first. | |
setActiveView(newContent: ContentControl, oldContent?: ContentControl): void | Sets the active view content control. | Deprecated |
setActiveViewFromViewport(viewport: ScreenViewport): boolean | Sets the active view content control based on the selected viewport. | Deprecated |
setContentLayoutAndGroup(contentLayoutDef: ContentLayoutDef, contentGroup: ContentGroup): void | Sets the Content Layout and Content Group | |
setFloatingWidgetContainerBounds(floatingWidgetId: string, bounds: RectangleProps): boolean | ||
waitUntilReady(): Promise<void> | Returns once the contained widgets and content controls are ready to use | |
create(providerOrFrontstage: FrontstageConfig | FrontstageProvider): Promise<FrontstageDef> Static | Creates a FrontstageDef and initializes it. |
Properties
Name | Type | Description | |
---|---|---|---|
bottomPanel Accessor ReadOnly | undefined | StagePanelDef | ||
contentControls Accessor ReadOnly | ContentControl[] | Gets the list of ContentControls. | |
contentGroup Accessor ReadOnly | undefined | ContentGroup | ||
contentGroupProvider Accessor ReadOnly | undefined | ContentGroupProvider | ||
contentLayoutDef Accessor ReadOnly | undefined | ContentLayoutDef | ||
contentManipulation Accessor ReadOnly | undefined | WidgetDef | ||
floatingContentControls Accessor ReadOnly | undefined | ContentControl[] | ||
frontstageProvider Accessor ReadOnly | undefined | FrontstageProvider | ||
id Accessor ReadOnly | string | ||
isApplicationClosing Accessor ReadOnly | boolean | ||
isReady Accessor ReadOnly | boolean | ||
isStageClosing Accessor ReadOnly | boolean | ||
leftPanel Accessor ReadOnly | undefined | StagePanelDef | ||
panelDefs Accessor ReadOnly | StagePanelDef[] | Gets a list of StagePanelDefs | |
rightPanel Accessor ReadOnly | undefined | StagePanelDef | ||
statusBar Accessor ReadOnly | undefined | WidgetDef | ||
toolSettings Accessor ReadOnly | undefined | WidgetDef | ||
topPanel Accessor ReadOnly | undefined | StagePanelDef | ||
usage Accessor ReadOnly | string | ||
version Accessor ReadOnly | number | ||
viewNavigation Accessor ReadOnly | undefined | WidgetDef |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.