StagePanelDef Class
A StagePanelDef represents each Stage Panel within a Frontstage.
Extends
Methods
Name |
Description |
|
constructor(): StagePanelDef |
Constructor for PanelDef. |
|
Inherited methods
Properties
Name |
Type |
Description |
|
location Accessor ReadOnly |
StagePanelLocation |
Location of panel. |
|
panelState Accessor |
StagePanelState |
Panel state. |
|
pinned Accessor |
boolean |
Indicates whether the panel is pinned. |
|
resizable Accessor ReadOnly |
boolean |
Indicates whether the panel is resizable. |
|
size Accessor |
undefined | number |
Current size of the panel. |
|
sizeSpec Accessor |
undefined | StagePanelSizeSpec |
Current size of the panel |
|
widgetDefs Accessor ReadOnly |
ReadonlyArray<WidgetDef> |
Gets the list of Widgets. |
|
Inherited properties
Name |
Type |
Inherited from |
Description |
widgetCount Accessor ReadOnly |
number |
WidgetHost |
Gets the number of Widgets. |
Defined in
Last Updated: 14 November, 2024