ContentGroupProvider Class
Abstract class that can be implemented and specified by frontstage to dynamically construct content group just prior to activating the frontstage.
Methods
Name | Description | |
---|---|---|
constructor(): ContentGroupProvider | ||
applyUpdatesToSavedProps(contentGroupProps: ContentGroupProps): ContentGroupProps | Allow provider to update any stored ContentGroupProps be it is to be used to create ContentGroup and layouts. | |
contentGroup(frontstage: FrontstageConfig): Promise<ContentGroup> Abstract | Return the contentGroup based on the Frontstage . |
|
onFrontstageDeactivated(): Promise<void> | Allow provider to save any content group data before the stage deactivated. | |
prepareToSaveProps(contentGroupProps: ContentGroupProps): ContentGroupProps | Allow provider to update any data stored in ContentGroupProps. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.