getContent Method
Deprecated in 4.5. Use getContentIterator instead.
Retrieves content which consists of a content descriptor and a page of records.
getContent(requestOptions: ContentRequestOptions<IModelConnection, Descriptor | DescriptorOverrides, KeySet, RulesetVariable> & ClientDiagnosticsAttribute & { batchSize?: number, maxParallelRequests?: number } & { paging?: PageOptions }): Promise<undefined | Content>
Parameter | Type | Description |
---|---|---|
requestOptions | ContentRequestOptions<IModelConnection, Descriptor | DescriptorOverrides, KeySet, RulesetVariable> & ClientDiagnosticsAttribute & { batchSize?: number, maxParallelRequests?: number } & { paging?: PageOptions } |
Returns - Promise<undefined | Content>
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.