ImageIdOverride Interface
Deprecated in 3.x. Use ExtendedDataRule instead. See extended data usage page for more details.
ImageId override rules allow setting an image ID to specific types of ECInstances.
@see Image ID override reference documentation page
Extends
Properties
Name | Type | Description | |
---|---|---|---|
condition | string | undefined | Defines a condition for the rule, which needs to be met in order to execute it. | |
imageIdExpression | string | An expression whose result becomes the image ID. | |
ruleType | "ImageIdOverride" | Used for serializing to JSON. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
onlyIfNotHandled Inherited | boolean | undefined | RuleBase | Tells the library that the rule should only be handled if no other rule of the same type was handled previously (based on rule |
priority Inherited | number | undefined | RuleBase | Defines the order in which rules are handled, higher number means the rule is handled first. |
requiredSchemas Inherited | RequiredSchemaSpecification[] | undefined | RuleBase | A list of ECSchema requirements that need to be met for the rule to be used. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.