ExtendedDataRule Interface

Extended data rule is used to inject some arbitrary data into presentation data objects (nodes, content records).

@see Extended data rule reference documentation page

Extends

Properties

Name Type Description
condition string | undefined Defines a condition which needs to be met in order for the rule to be used.  
items { T } A map of ECExpressions whose  
ruleType "ExtendedData" Used for serializing to JSON.  

Inherited properties

Name Type Inherited from Description
onlyIfNotHandled Inherited boolean | undefined RuleBase Tells the library that the rule should only be handled if no other rule of the same type was handled previously (based on rule
priority Inherited number | undefined RuleBase Defines the order in which rules are handled, higher number means the rule is handled first.
requiredSchemas Inherited RequiredSchemaSpecification[] | undefined RuleBase A list of ECSchema requirements that need to be met for the rule to be used.

Defined in

Last Updated: 14 November, 2024