ContentRule Interface
Content rules are used to define content that is displayed for specific type of input.
Input consists of either ECInstances or nodes and to make things
simpler everything is considered a node - instances get converted to
ECInstance nodes (thus the SelectedNode
symbol in condition
ECExpression).
@see Content rule reference documentation page
Extends
Properties
Name | Type | Description | |
---|---|---|---|
condition | string | undefined | Defines a condition which needs to be met in order for the rule to be used. | |
ruleType | "Content" | Used for serializing to JSON. | |
specifications | ContentSpecification[] | A list of content specifications that define what content is going to be returned. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
onlyIfNotHandled Inherited | boolean | undefined | RuleBase | Tells the library that the rule should only be handled if no other rule of the same type was handled previously (based on rule |
priority Inherited | number | undefined | RuleBase | Defines the order in which rules are handled, higher number means the rule is handled first. |
requiredSchemas Inherited | RequiredSchemaSpecification[] | undefined | RuleBase | A list of ECSchema requirements that need to be met for the rule to be used. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.