CheckBoxRule Interface
Deprecated in 3.x. Use ExtendedDataRule instead. See extended data usage page for more details.
CheckBox rules provide a way to create a checkbox for specific types of ECInstance's.
@see CheckBox rule reference documentation page
Extends
Properties
Name | Type | Description | |
---|---|---|---|
condition | string | undefined | Defines a condition for the rule, which needs to be met in order to execute it. | |
defaultValue | boolean | undefined | Default value to use for the check box state | |
isEnabled | string | boolean | Indicates whether check box is enabled or disabled. | |
propertyName | string | undefined | Name of boolean type ECProperty which is bound with the check box state. | |
ruleType | "CheckBox" | Used for serializing to JSON. | |
useInversedPropertyValue | boolean | undefined | Should property value be inversed for the check box state. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
onlyIfNotHandled Inherited | boolean | undefined | RuleBase | Tells the library that the rule should only be handled if no other rule of the same type was handled previously (based on rule |
priority Inherited | number | undefined | RuleBase | Defines the order in which rules are handled, higher number means the rule is handled first. |
requiredSchemas Inherited | RequiredSchemaSpecification[] | undefined | RuleBase | A list of ECSchema requirements that need to be met for the rule to be used. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.