SingleElementPropertiesRequestOptions<TIModel, TParsedContent> Interface
Request type for single element properties requests.
Extends
- RequestOptions<TIModel>
Properties
Name | Type | Description | |
---|---|---|---|
contentParser | (descriptor: Descriptor, item: Item) => TParsedContent | undefined | Content parser that creates a result item based on given content descriptor and content item. | |
elementId | string | ID of the element to get properties for. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
imodel Inherited | TIModel | RequestOptions<TIModel> | iModel to request data from |
locale Inherited | string | undefined | RequestOptions<TIModel> | Optional locale to use when formatting / localizing data |
unitSystem Inherited | UnitSystemKey | undefined | RequestOptions<TIModel> | Unit system to use when formatting property values with units. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.