PropertyInfo Namespace
Function
Name | Description |
---|---|
PropertyInfo.fromJSON | Deserialize PropertyInfo from JSON |
PropertyInfo.toCompressedJSON | Serialize PropertyInfo to compressed JSON |
PropertyInfo.toJSON | Serialize PropertyInfo to JSON |
Defined in
PropertyInfo Interface
A structure that describes an ECProperty
Properties
Name | Type | Description | |
---|---|---|---|
classInfo | ClassInfo | Information about ECProperty class | |
enumerationInfo | EnumerationInfo | undefined | Enumeration info if the property is enumerable | |
extendedType | string | undefined | Extended type name of the ECProperty if it has one | |
kindOfQuantity | KindOfQuantityInfo | undefined | Kind of quantity information, if any. | |
name | string | Name of the ECProperty | |
navigationPropertyInfo | NavigationPropertyInfo | undefined | Navigation property info if the field is navigation type | |
type | string | Type name of the ECProperty |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.