NavigationPropertyInfo Namespace
Contains utilities for working with objects of NavigationPropertyInfo type.
Function
Name | Description |
---|---|
NavigationPropertyInfo.fromCompressedJSON | Deserialize NavigationPropertyInfo from compressed JSON |
NavigationPropertyInfo.fromJSON | Deserialize NavigationPropertyInfo from JSON |
NavigationPropertyInfo.toCompressedJSON | Serialize NavigationPropertyInfo to compressed JSON |
NavigationPropertyInfo.toJSON | Serialize NavigationPropertyInfo to JSON |
Defined in
NavigationPropertyInfo Interface
A data structure for storing navigation property information.
Properties
Name | Type | Description | |
---|---|---|---|
classInfo | ClassInfo | Information about ECProperty's relationship class | |
isForwardRelationship | boolean | Is the direction of the relationship forward | |
isTargetPolymorphic | boolean | Is ECProperty's target class polymorphic | |
targetClassInfo | ClassInfo | Information about ECProperty's target class |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.